Dreamweaver Reference Guide

Create hyperlink to a document ................................................................................................................. 12
Create email address hyperlink .................................................................................................................... 13
Inserting Images ........................................................................................................................................... 13
Tables ............................................................................................................................................................ 13
Meta tags – Make Your Pages Searchable ..................................................................................................... 14
   Adding Description ..................................................................................................................................... 14
   Adding Keywords ....................................................................................................................................... 14
   Edit meta tag info ....................................................................................................................................... 15

About this reference guide
This reference guide touches on common features used in web design. It is not intended to be all inclusive. Enrollment in web design classes or self-study is highly recommended.

Open Dreamweaver
If you do not have a site set up in Dreamweaver, you may receive a message indicating you need to set one up.
   • Faculty/Staff - see tutorial called “Set Up Your Site” at http://www.bloomu.edu/technology/web
   • Students – see tutorial called Student Guide – “Set up your site in Dreamweaver...” at
     http://www.bloomu.edu/technology/student/web
Dreamweaver Reference Guide

Recommendations for Software Setup

Toolbars
If you have not already started creating a new document, click File-New to create a new document. Click View-Toolbars and make sure “Document,” and “Standard” are available.

Layout Tools
Click Window and make sure to click on “Insert,” “Properties,” and “Files.” This will ensure the following screen features are available:

“Insert” provides tools in the form of shortcut icons, such as the ability to easily insert images, tables, etc.

“Files” ensures you are able to view your local site files in this panel.

“Properties” ensures a place to edit HTML and CSS.
Dreamweaver Reference Guide

Properties panel for formatting
If this isn’t open in your Dreamweaver screen, click Window-Properties to open it. This area allows you quick formatting options such as highlighting text and using the Bold or Italic features, centering, linking, changing colors, etc.

The properties panel may be toggled between CSS and HTML.

![Properties Panel](image)

Default Browser
As you create pages, you will be able to preview your webpage to see how it will look once it is published. You will have to save your page prior to previewing it. Preview by clicking on the “globe” icon.

![Default Browser](image)

By default, Internet Explorer is set as the primary web browser for previewing.
To change this, click Edit Preferences – select “Preview in Browser” category

Add a browser by clicking the + sign
Delete a browser by highlighting it and clicking the - sign
Click APPLY when finished!

![Edit Preferences](image)

Highlight the browser you wish to use as your primary browser and click the checkbox in front of Primary Browser.
Keyboard Shortcuts
Familiarize yourself to keyboard shortcuts by clicking on Edit-Keyboard Shortcuts, which will show you all shortcuts available.

Popular shortcut commands
Use Control N to create a new page
Use Control S to save a page
Use Control Z to undo an action or keystroke
Press the Shift key plus the Enter key to force single spacing

Document View/Design Choices
There are three icons which allow a choice for how you wish to design your pages – Code, Split, or Design. A description of each follows ~ you can choose which option(s) work best for you!

Design
Using this option you will see no coding at all. This screen shows you an approximation of how the page will look once it is on the web. Note that this is only a guide to the visual characteristics of the page. To see how the page truly looks, use the Preview in Browser button found in the title toolbar.

Split
Using this option you will see a split screen. One portion of the screen shows code and another shows design view. It is often helpful to examine code if something isn’t working correctly.

Code
Using the option called Code, you will see code only.
Live View
A newer feature in Dreamweaver, this is an option used for dynamic pages, such as those interfaced with databased or multimedia. A testing server would need to be set up to use this feature.

Creating a basic webpage
Click File-New. Choose Blank Page.

Title your webpage
The toolbar directly underneath the text menus contains the Title toolbar. Enter the title for your page in the space provided.

Adding a title to your page is important! The title shows in the Internet browser window once your page is published. If a title is not added, the browser window would say "Untitled Page."

In addition, if someone bookmarks your page, their bookmark will show the title.

Formatting and Manipulating Text
Use the Properties window to assist with formatting.

Bold and Italic
Similar to formatting options available in Word and Excel, the properties panel may be used for bolding and italicizing text, centering, adding bullet points, etc.

Headings
Make certain the Properties panel is defaulted to <>HTML to use headings!
Dreamweaver Reference Guide

Headings 1 through 6 are available under the Format dropdown.

Select a heading and type your text. If you forget to apply a heading to your typed text, highlight the text and choose heading.

➤ Use of headings greatly helps web visitors using screen readers. Screen readers read web pages to someone visiting a website. If a piece of text is identified as a heading, the screen reader will announce that it's a heading. If not, screen reader users won't be able to tell your headings from the rest of your text. They will have to listen to the page in its entirety rather than having the option to jump from one main heading to another.

Heading 1

Heading 2

Heading 3

Line Spacing

As you type, text will be wrapped automatically and you will have single spacing. Pressing the Enter key will insert a new paragraph and give you double spacing. To control spacing, i.e., if you wish to type a line and only want single spacing for the next line, follow these steps:

➤ Type a line.
➤ Press Shift key plus the Enter key. You will now control the spacing to be single spaced. You may also use the BR feature under the Insert menu.

![Insert-Text-BR symbol](image)

Press the Enter key when you are ready to insert a new paragraph.

Save a webpage

Your page will say “Untitled” with a number and a dash next to it until it is saved and given a name. When ready to save, click File-Save As (or hold Control key down and press S). Type a name for your page and click the Save button.

➤ Reminder: Home pages must be named index.html or index.htm
➤ Reminder: If your page name contains more than one word, type words together with no space, or add an underline between names. Examples: page1.html or page_one.html
Asterisk * in file name
An asterisk next to a file name indicates there have been changes made to the page and it needs to be saved. Once saved, the asterisk will disappear.

Saving several pages
Have several pages open? Save them all at once by clicking File-Save All!

File extensions - html or htm?
Either extension is fine to use but it is suggested you pick one and use that consistently. Lowercase is also suggested, i.e., index.html

Have several pages open
You may have the need to open several pages to work on them concurrently. Once they are open, you will see tabs available for the different documents you have open. You can switch back and forth by clicking on a tab.
Bullets and Lists

Lists
The circled items below assist with creation of lists. The most commonly used lists are UL (unordered lists, also known as bullet points) and OL (ordered lists, also known as numbered lists). Examples below and OL (ordered lists).

Sample ~ UL
- computers
- desks
- chairs

Sample ~ OL
1. computers
2. desks
3. chairs

NOTE: To use lists, follow one of the following steps:
1) Type the list first. When finished, highlight all the text and use the list buttons.
2) Click on the list button and then begin typing your list. As you press Enter to go to the next item a new bullet point or number will be inserted for you.
**Dreamweaver Reference Guide**

**Insert Menu Options (for special characters, inserting images, creating hyperlinks)**

The insert tab should be available on the right side of your Dreamweaver window. If it is not there, click Window-Insert.

This will allow you to use the tools to do links, lists, tables, anchors, etc.

Once you have access to the Insert window, there is a dropdown you can click to reach other tools available in different menu subsections.

![Insert Menu Options](image)
Special Characters and Symbols
Using the Insert tab, be sure you are on the Common dropdown.

You will see a clickable button for Characters. You can access special characters, such as copyright or trademark, along with other characters.

Create hyperlinks
Hyperlinks can be added using the Insert tab ... or the Properties Window.

The following examples are shown using the Properties window.

Make sure this window is available by clicking Window along the top tool bar in Dreamweaver. If there is a checkmark in front of Properties, you are good to go. If there is no checkmark, click the word Properties. You should now see the Properties window at the bottom of your Dreamweaver screen.
Create hyperlink to a web page

Type text and highlight any text you wish to use as a hyperlink. Add the link info in the Link field. If you wish to have the browser open the clicked link in a new page, use the Target field and choose _blank.

Editing a link

Should you need to edit the link, click directly on the hyperlinked text. Change the information in the properties window.

Create hyperlink to a document

Type a line of text. Highlight the word or phrase you wish to use as a link to a document, and then create the link information in the properties window by using the file folder icon to browse to the document you wish to link to.
Create email address hyperlink

Using the <>HTML portion of the Properties Window:
Type text and highlight it. In the link area, type the email address, preceded by the word “mailto” – Example: mailto:johl@bloomu.edu

Inserting Images

Images must always be resized prior to adding them to a webpage!
- Images may be resized directly in Dreamweaver, or by using photo editing software.

Once your image has been resized, it must also be published to your website. We always recommend using a subfolder in your website called images and place all images in that folder.

When ready to add the image to your webpage, after it has been resized and published, use the Insert tab or click along the top menu – Image – Image. Navigate to the image you wish to add and click through to add it.

Tables

Tables may be used for a variety of things.
- Displaying tabular data
- Controlling image and text placement
- Controlling page layout

Visit the “Tables” tutorial at http://www.bloomu.edu/documents/tech/web/tables.pdf for an explanation and hands-on tutorial!
Meta tags – Make Your Pages Searchable

Inserting meta tag information into your pages can assist with browser search engines and help people find your pages. The content you add is not visible to web visitors as it coding embedded in your pages for search purposes. (Note: Some search engines do ignore meta tags.)

The two main features commonly used are Keywords and Description.

To insert meta tag info, click Insert > Head > Keywords or Description

Adding Description
The description text is what will be displayed on the search engine page so write well!

Insert > Head > Description

The following window appears – type your text – example

Adding Keywords
Keywords are descriptive words that assist people using search engines. Think of the way you search and use keywords you think would assist people in finding your web site. **Hint:** Separate words by commas, don't repeat words, keep the list short and specific to your site. Most reference books warn to only use 10-15 words.

Insert > Head > Keywords
Dreamweaver Reference Guide

Edit meta tag info

Probably the easiest way to edit meta tag info is to go into "split" view mode and make sure you scroll all the way to the top of your page. You will see the meta info on the screen. You may click right into the code view and make necessary changes.