Dreamweaver – Create a Template from Scratch

Outline
Outline................................................................................................................................................................................................................ 1
What is a template? ........................................................................................................................................................................................... 2
Layout................................................................................................................................................................................................................. 2
Create a folder for your local copy of your website ...................................................................................................................................... 2
Set Up Site in Dreamweaver to point to newly created folder .......................................................................................................................... 3
Creating a Template Page .................................................................................................................................................................................. 3
   Add a title ....................................................................................................................................................................................................... 4
Link to CSS Style Sheet, if desired ...................................................................................................................................................................... 5
Build a Table Structure for your page ................................................................................................................................................................ 5
   Adding Navigation Text & Web Site Banner .............................................................................................................................................. 7
Add an Editable Region ...................................................................................................................................................................................... 8
   Save your page as a Template........................................................................................................................................................................ 9
Creating New Pages Using Your Template ....................................................................................................................................................... 11
   Create additional pages for about, classes and contact .............................................................................................................................. 12
   When pages are complete ........................................................................................................................................................................... 12
Edit template to add links to new pages .......................................................................................................................................................... 13
   Not sure how to create a link? ..................................................................................................................................................................... 13
   After all links have been established............................................................................................................................................................. 13
Ready to publish! .............................................................................................................................................................................................. 14
   Edit Site Setup .............................................................................................................................................................................................. 14
      Local Info Tab ........................................................................................................................................................................................... 14
      Remote Info Tab ....................................................................................................................................................................................... 15
   Publish your site ............................................................................................................................................................................................ 16
      To publish an entire new site ................................................................................................................................................................... 16
Future Site Edits ............................................................................................................................................................................................... 16
   Template Edits ........................................................................................................................................................................................... 16
   HTML Page Edits........................................................................................................................................................................................... 16
Dreamweaver – Create a Template from Scratch

What is a template?
A template is a master page that serves as a pattern for all your web pages. Websites usually follow a standard structure, example: a header and navigation structure, common to all pages. Templates help provide a consistent look and feel across all the pages of your website. Imagine your site has 25 or more pages. To make one small change, possibly adding or deleting a link in your navigation area, you would only need to revise the template and all other pages built from the template are updated automatically!

Templates function through use of "Editable Regions" - these regions are defined as part of a template and serve as the place where specific page information can be built. The remainder of the template is "locked" and can be edited within the template only. This locked area is the portion of the page that is common to all pages connected to a template, i.e., page headings and links. Because this information is stored in the "locked" area of the template, any changes made to this area can be easily propagated to all pages connected to the template.

Layout
The first and most important step in creating a template is to decide what you would like your site to look like. This is very easy, take a piece of paper and sketch out where you want the 2 major components of your site to be. Would you like your navigation links on the top, left side or right side? Then where would you like the editable region (the body text) to be.
Note: Dreamweaver does provide some predefined starter pages for you. There is a tutorial on the web support page on using a starter page to create a template for your site.

Create a folder for your local copy of your website
This exercise assumes you are just beginning with a new site and have no folder structure created as of yet. If you have a site already in existence but wish to start from scratch create a new folder for this purpose.
Create a new folder on your P drive for your new website. We also recommend creating a subfolder called images in which you may store all images for your site and a subfolder called documents in which you may store all documents you plan to link to.

(Note: If there will be multiple people maintaining your site, you may want to put the local folder on a network drive where all people have access to it.)
Set Up Site in Dreamweaver to point to newly created folder

If you do not have Dreamweaver open, you may open it now. You must first do site setup so Dreamweaver is directed to the correct folder structure. Click on Site-Manage Sites. Click New.

Using the Advanced tab, enter a Site Name (it can be called simply Facstaff if you are doing a facstaff web). This example we’re going to call it TemplateWebsite. Local root folder: Click on the folder to the right of the white text field and navigate to the new folder you just created.

Click OK when you have that much filled in. You should now see the new folder structure under Files on the right side of your Dreamweaver window.

Important note! This tutorial only takes you through setting up your local info in the site setup. When you are ready to publish files to the remote server, you must fill in the Remote Info on Site Management. You will click on Site-Manage Sites and then Edit the site. See detail on the Office of Technology website called "Set Up Your Site" and follow directions for setting up a website.

Creating a Template Page

Click File > New…

Click the “Blank page” tab, in the left column click “HTML”, for Layout choose “<none>”. Then click “Create” button.
Dreamweaver – Create a Template from Scratch

This will create your template page with nothing on it. Below you will learn how to setup your template layout using tables. You will notice that Dreamweaver created nothing more than a plain blank page.

Add a title
Change the “Untitled Document” text in the title bar to “My Website” – or whatever text you would like it to say. This will be what shows up in the browser bar.

Add title in Dreamweaver
Link to CSS Style Sheet, if desired

Link to a style sheet if you would like to use one. For information about creating and linking to a style sheet, visit the [CSS tutorial](#).

Build a Table Structure for your page

Tables are one of the most basic layout tools available. One master table will be used to align your entire page. This will be accomplished through the merging of cells. Add a table by clicking Insert-Table or use the table icon on the “Common” toolbar.

This will then open up the table property window:

**Rows and Columns** – Enter 4 in the field for Rows and Columns.

**Table Width** – Determines how wide your page is going to be. We recommend using a fixed amount (pixels) versus using a percentage. **For this example please use 100%**.

**Border Thickness** – How thick you would like the lines of your table. (When using a table to do a page layout it is best to use “0” so that the table lines aren’t visible.)

Click “OK”
Dreamweaver – Create a Template from Scratch

This is what your screen should now look like:

Now you format the table to use as a navigational bar for your template. Click inside the first row, anywhere.

Use the “tags” located at the bottom of the design window and select the `<tr>` tag. This will select the entire first row.

Now that the first table row is selected we are going to merge the cells to create our web site banner. Click on the merge icon in the Properties window at the bottom of the screen.
Next merge the bottom row (4th row) together. You table should look as follows:

![Table diagram]

**Adding Navigation Text & Web Site Banner**

In the first row type in “My Website.” Make the text heading 1 and center it.

Next type in the following text into the second row of the table, each word being in its own cell: Home, About, Classes, Contact. Center the text in the cells. When you are finished typing in the last text item, click in another cell - Dreamweaver re-align your table. If you don’t like the spacing between columns, drag on the vertical bar and drag.

Your table should look like this:

![Table diagram]
Add an Editable Region

An editable region needs to be inserted into your template. This region is going to be the area that will be different on every page; this is where you will place the content of the page.

Click in the 4th row to place your cursor in that row.

Click Insert > Template Objects > Editable Region

A window will pop up and ask you to name the region. Label it “Content”

Click “OK”

Notice that you have a cyan box labeled “Content” in the last row.
Dreamweaver – Create a Template from Scratch

**Save your page as a Template**

Click **File > Save as Template**

Dreamweaver will open up a window that will ask you which site you would like the template for, and it asks you to name your template.
Dreamweaver – Create a Template from Scratch

Make sure that your Site Name is displayed in the “Site” drop down box. Type in “horizontal_nav” and click “OK.”

**Note:** You may name your template any name you choose; this exercise is naming it horizontal_nav because we are creating a horizontal navigation bar.

You should now see a Templates folder in your Local files area with a newly created template in it. Dreamweaver applies a .dwt extension to the file name.
Dreamweaver – Create a Template from Scratch

Creating New Pages Using Your Template

Now that you have created your template page you will need to know how to use the template to create your web site. You are going to use the site that you have already set up in Dreamweaver and you are going to create new pages based on the template.

1. With Dreamweaver open all you have to do is go to “File,” “New…”

2. Dreamweaver will then open up the menu that you will use to select your template. Make sure that you select “Page from Template” on the left.

3. Select your site in the left column.*

4. Then select your template in the right column

You will notice the Dreamweaver provides a preview of your template in the window to the right

5. Click on “Create”

* This screenshot shows many Sites listed in the 2nd column because I am responsible for many sites. You will likely not have many items listed in the 2nd column.
Dreamweaver – Create a Template from Scratch

You will notice immediately when creating a page from a template that you cannot click in any other area of the page except the content area. All other areas of the page are locked and must be edited in the template only.

Customize your page – the first page will be your home page. Make sure the title is correct and add pertinent text to the content area. When ready to save, click File > Save As > name your home page index.html – home pages must always be named index.

Create additional pages for about, classes and contact
You may go back to the beginning and click File > New > Page from Template >

OR

Simply have the index page open, customize it for “about” info – then click File > Save As > Name it about.html
- Customize next with classes info. Click File > Save As > Name it classes.html
- Customize next with contact info. Click File > Save As > Name it contact.html

Tip: When creating a name for your pages, short names and lowercase letters are best. If your page name must have 2 or more words in it, close the spaces up between words. Example: web_links.html or webLinks.html

When pages are complete
Once you have customized and save your pages, you should see four HTML pages in total. The pages will show up in your Local Files panel, as illustrated.
Dreamweaver – Create a Template from Scratch

Edit template to add links to new pages
Open the template under the Templates folder by double clicking on it. It’s now time to create links to your new pages along the navigation bar.

Double click the word Home – Create a link to the index.html page
Double click the word Classes – Create a link to the classes.html page
Highlight the words Contact – Create a link to the contact.html page

Not sure how to create a link?
After highlighting the word(s), use the Properties panel link area. Either use the folder to browse to the correct html file

or use the Point to File icon (click and drag to file you wish to link to)

After all links have been established
Click File > Save.
You will see a message asking if you want to update all files based on the template – choose Update!! This will ensure that the links will work on all pages in your site that have been created based on this template.

You will see a log file telling you if all files were updated. You may close this and then close the template.
Dreamweaver – Create a Template from Scratch

Ready to publish!

Once all pages have been created and all links have been correctly established, you are ready to publish. You will need to revise your site setup (the site setup we did at the beginning of this exercise was just to establish the connection to the local folder.

Note: These instructions assume you are doing a facstaff website. If you are doing a departmental or organizational site, or if you work in the College of Business and have your website setup on the COB server, visit the site setup tutorial on the OT web support page.

Edit Site Setup

Local Info Tab

Click Site > Manage Sites > highlight your site and choose Edit
Use the Advanced tab and under Local Info, make sure you have the HTTP address for your site. The screen shot below shows an example of how to set up a facstaff HTTP address *(put your user name in the space after bloomu.edu/______)*

Have a checkmark in Enable cache

The local root folder and default images folder should be whatever name you selected for your site folder. This is an example of site setup.

The HTTP address for a facstaff web is http://facstaff.bloomu.edu/username (your user name)
Dreamweaver – Create a Template from Scratch

Next click Remote Info under Category

Remote Info Tab
If you are creating a facstaff web, below is how you will set up your remote info tab. If you are doing a departmental or organizational site, or if you work in the College of Business and plan to have your web on the COB server, visit the directions on the site setup tutorial on the OT web support page.

Setup for Facstaff Account
Access – FTP
FTP Host: facstaff.bloomu.edu
Login: YOUR network logon (what you use to log into your computer)
Password: YOUR network password

The following screenshot shows an example of how to setup the remote info tab for a facstaff web.
Dreamweaver – Create a Template from Scratch

Publish your site
Once you have setup your site correctly, you are ready to publish.

To publish an entire new site
1) Click on the top level folder.
2) Click the blue Up arrow.

This will “put” the entire set of files on the remote server, thereby allowing your web visitors to see your site.

Future Site Edits

Template Edits
If you have edits to the template (links, color, design), open the template, edit and save. When saving, a window will appear, asking if you want to update all pages based on the template. Choose YES.

You must then publish the pages affected by this change (the template and any HTML files.) Highlight the file(s) and then click the blue UP arrow.

HTML Page Edits
If you wish to edit the content of any HTML page(s), open the page, do edits and save. Close page, highlight it in the Local Files area and click the blue UP arrow.